Как добавить кнопки в действия

Добавления новой кнопки происходит в меню «Действия» списка документа.

Для определения заголовка кнопки используется функция ЗаполнитьСписокДополнительныхКнопок.

Формирование списка кнопок происходит в основной форме модуля при изменении режима отображения документов.

Пример добавления кнопки для выполнения сопоставления отправленных документов:

РежимОтображенияДокументов = Параметры.РежимОтображенияДокументов;
ТаблицаКнопок = Параметры.ТаблицаКнопок;

Если РежимОтображенияДокументов = "ОтправленныеДокументы" Тогда

    НовСтрока = ТаблицаКнопок.Добавить();
    НовСтрока.Имя       = "СопоставитьОтправленныйДокумент";
    НовСтрока.Заголовок = "Сопоставить документ";

КонецЕсли;

Алгоритм действия новой кнопки описывается в функции НажатиеДополнительнойКнопки.

Вызов происходит из основной формы модуля при нажатии на дополнительную кнопку.

Пример выполнения сопоставления отправленных документов при нажатии на кнопку:

РежимОтображенияДокументов = Параметры.РежимОтображенияДокументов;
ВыделенныеСтроки = Параметры.ВыделенныеСтроки;
ИмяКнопки = Параметры.ИмяКнопки;

Если РежимОтображенияДокументов = "ОтправленныеДокументы" И ИмяКнопки = "СопоставитьОтправленныйДокумент" Тогда

    Для Каждого ВыбраннаяСтрока Из ВыделенныеСтроки Цикл
        Если ЗначениеЗаполнено(ВыбраннаяСтрока.ДокументЭДО) Тогда

            РезультатФункции = ОсновнойМодуль.НайтиИСопоставитьДокументДД(ВыбраннаяСтрока.ДокументЭДО, ВыбраннаяСтрока.Пакет);
            ОсновнойМодуль.ОбработатьРезультатФункции(РезультатФункции);

        КонецЕсли;
    КонецЦикла;

КонецЕсли;